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What is Masterplan? 

Masterplan is an application that helps you to build D&D 4E campaigns. You can outline 
your plot structure, build encounters and maps, detail your campaign world, and create 
custom creatures and NPCs. 

We call it the Adventure Design Studio. We think you’ll enjoy it. 
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CREATING A PROJECT 

The screen you will see when first running Masterplan is this: 

 

To create a project select Create a new project (or select New Project from the File menu, 
or press Ctrl+N). You will be asked for the name of your project, the number of characters in 
the party, and the party level. You can also specify the party’s starting XP value if you wish. 

 

To change this information later, select Project Properties on the Project menu. 
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THE PLOT WORKSPACE 

Masterplan allows you to create and link plot points to outline the flow of your plot. 

 

You can add and remove plot points from the toolbar. Double-clicking on a blank area of the 
workspace will also allow you to add a plot point. Double-clicking on a plot point, or 
selecting Edit Plot Point from the toolbar, allows you to edit it. 
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A plot point which has information on the Details page (either description or read-aloud 
text) will be shown in the workspace with its corner turned up. 

LINKING PLOT POINTS TOGETHER 

There are many ways in which you can organise your workspace: 

 To create a point with a link to an existing point, right-click on the point and select 
Add Point. 

 To create a link between two points, left-click and drag the second point onto the 
first. 

 You can re-order plot points by dragging them left or right; an I-beam will appear to 
indicate where the dragged plot point will be moved to. 

 If you add a link between two points that you later want to remove, right-click on 
one of the points, select Disconnect From, and then select the name of the other 
point. Alternatively, double-click on one of the points and use the Plot Connections 
page to remove the link. 
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SUBPLOTS 

Each plot point can contain its own subplot. To keep your workspace clean, you can use 
subplots to define more complex pieces of your plot. If a plot point has a subplot, it will be 
shown with a double border. 

To create or view a point’s subplot, select the point and press Explore Subplot on the 
toolbar, or hold shift while double-clicking on the plot point. This will bring you to the 
point’s subplot, where you can create plot points and link them together as usual. 

You can right-click on a plot point and select Move to Subplot to move that point into to the 
subplot of one of the points that leads into it. 

 

To return to the main plot, you can use the link at the bottom of the screen. 

NAVIGATOR 

If you have a plot with multiple subplots, you might find the navigation panel useful. It can 
be turned on from the View menu. The navigation panel shows all the subplots in your 
project, allowing you to switch between them easily. 

You can also drag and drop plot points between subplots using the navigator. 
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SEARCH 

If you have a complex plot, you can use the Search function on the toolbar to find 
information. When you type in the search box, any points that do not contain the search 
terms are displayed only in outline form. 
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USING VIEWS 

You can use the options on the View menu to show only those plot points which contain 
encounters, traps, skill challenges, quests and treasure parcels. 

By default Masterplan will show you the places where the PCs are likely to have gained 
enough XP to level up; you can disable this option by deselecting Levelling on the View 
menu. The amount of XP the party gains can be calculated in two ways: 

 If Maximum Available XP (on the Flowchart menu) is selected, Masterplan assumes 
the PCs will get XP from all plot points. 

 If Maximum Available XP is not checked, Masterplan assumes that where there are 
multiple plot points in a horizontal row, the PCs will gain the average of the different 
amounts available. 

Another option on the View menu is Highlighting; this will highlight the plot points which 
are linked to the currently selected point. This can be useful if you find it difficult to track 
the flow of a complex plot. 

COMPLETED / SKIPPED PLOT POINTS 

You can right-click on a plot point in the workspace to specify that it has been completed by 
your party or skipped altogether; such plot points are dimmed in the workspace. 

Any XP which would be granted by skipped plot points is not counted. 

ADJUSTING DIFFICULTY 

If you want to quickly make an entire plot more or less difficult, you can do so easily. First 
open the plot or subplot in the workspace, and then select Adjust Difficulty from the 
Advanced button on the toolbar; you can then specify how many levels more or less difficult 
you want the plot to be. 
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When you press OK, each creature, trap, skill challenge and quest in the plot will be 
automatically adjusted up or down. 

DELVE VIEW AND MAP VIEW 

By default Masterplan assumes you’re creating your plot structure first, and then creating 
maps to accommodate it. However, you may prefer to work in the other direction, creating 
a map first and then populating it with encounters. 

If you would like to do this, the right-hand panel contains a link to activate Delve View or 
Map View, which allow you to select (or create) a map which will replace the flowchart in 
the workspace. 

 If you want to work from a tactical map (for example, you are creating a dungeon 
delve and want to set up an encounter for each room), select Delve View. 

 If you want to work from a regional map (for example, you are detailing various 
encounters and skill challenges that might occur as the heroes travel around a city), 
select Map View. 

You can then select map areas and create plot points (encounters, skill challenges, etc) from 
them. 

 

For information about how to create tactical or regional maps, and how to add areas and 
locations to them, see the relevant sections later on in this manual. 
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PARTY GOALS 

If the plot workspace seems too daunting, you can instead define party goals by clicking on 
the Party Goals link. 

Typically a plotline will have a single top-level goal, representing the party’s primary quest. 
Beneath this goal there may be several prerequisite goals, representing the complications 
which must be overcome to complete the primary quest. This structure can be extended 
many levels deep, and goals can be dragged and dropped into new locations as desired. 

 

When you press OK the goal structure will be used to build a plotline automatically. 
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GAME ELEMENTS 

Plot points can contain various types of game element: encounters, traps, skill challenges, 
quests and maps. 

 

ENCOUNTERS 

Plot points can contain encounters. To add an encounter to a point, double-click on it; on 
the Game Elements page click the Combat Encounter link. 
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To add creatures to an encounter, click the Edit button to bring up the Encounter Builder. 

 

The panel at the bottom left of the encounter builder shows the appropriate XP values and 
creature levels that are appropriate for a party of the given size and level. By default, 
creatures of lower or higher levels are not shown in the right-hand list (you can override this 
by deselecting Filter by Level from the Filter List menu on the right-hand list). 
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If the encounter poses an inappropriate challenge (either too easy or too difficult), the plot 
point will turn red in the workspace. 

If you press the Expand link you can use various criteria to filter the creatures in the list. 

 

ADDING CREATURES 

You can add creatures to the encounter by selecting them from the list on the right and 
dragging them into the list on the left. The XP value and difficulty of the encounter will be 
updated automatically and shown at the bottom of the screen. 

You can change the number of creatures in the encounter by selecting a creature and using 
the + and – buttons. If you reduce the number of a particular creature to 0, it will be 
removed from the list. 

If you hold down the Shift key when pressing the + or – buttons a level adjustment will be 
applied, allowing you to quickly change the level of a standard creature. The creature’s level, 
XP value, defences, hit points and attack bonuses will be updated accordingly. To remove a 
creature’s level adjustment, select it and choose Remove Level Adjustment from the Edit 
menu. 
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If you select a creature in the encounter and choose Set Faction from the Edit menu you can 
mark creatures as being neutral (in which case they will not add to the encounter XP value) 
or allied (in which case their XP value is subtracted from the XP total). 

ADDING CREATURE TEMPLATES 

You can add templates to the creatures in an encounter by selecting Creature Templates 
from the toolbar above the right-hand list (this option will not be available if no templates 
have been defined). Select a template and drag it onto a creature to apply the template to 
that creature; the encounter’s XP value will be updated accordingly. 

 

To remove a template from a creature, select it and choose Remove Template from the Edit 
menu. 

ADDING MONSTER THEMES 

You can add a theme to a creature in an encounter by opening the encounter builder, 
selecting the creature, and selecting Apply Theme from the Edit menu. 
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This screen allows you to select (or create) a monster theme, and to choose the attack and 
utility powers granted by it. 

To remove the theme from the creature, select Clear Theme from the Edit menu. 

If you want to apply a theme to all the creatures in the encounter, rather than a single 
creature, select Apply Theme to All from the Tools menu. Select a theme and each different 
type of creature in the encounter will be updated with an appropriate attack and utility 
power from the theme. 

ADDING NPCS 

You can add NPCs to an encounter by selecting NPCs from the toolbar above the right-hand 
list (this option will not be available if your project contains no NPCs). Select an NPC from 
the right-hand list and drag it onto the left-hand list to add it to the encounter; the 
encounter’s XP value will be updated accordingly. 
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ADDING TRAPS AND HAZARDS 

There are two ways to add traps and hazards to your encounter: 

 You can add a predefined trap or hazard by selecting Traps / Hazards from the 
toolbar above the right-hand list (this option will not be available if no traps have 
been defined). Select a trap and drag it into the left-hand list; the encounter’s XP 
value will be updated accordingly. 

 You can add a custom trap or hazard by selecting Custom Trap / Hazard from the 
Tools menu. 

You can remove a trap from the encounter by selecting it and pressing Remove on the 
toolbar. 

ADDING SKILL CHALLENGES 

There are two ways to add skill challenges to your encounter: 

 You can add a predefined skill challenge by selecting Skill Challenges from the 
toolbar above the right-hand list (this option will not be available if no skill 
challenges have been defined). Select a skill challenge and drag it into the left-hand 
list; the encounter’s XP value will be updated accordingly. 

 You can add a custom skill challenge by selecting Custom Skill Challenge from the 
Tools menu. 

You can remove a skill challenge from the encounter by selecting it and pressing Remove on 
the toolbar. 

USING ENCOUNTER TEMPLATES 

You can choose to build your encounter using one of the defined encounter templates. 
Encounter templates define groups of creatures which work well together in a combat 
encounter. 

Select Use Encounter Template from the Tools menu to see a list of the encounter 
templates that are available (this list may change depending on the project level and the 
available creatures). 
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Select a template and press Next. You will then be asked to fill each of the slots in the 
template by selecting a creature for it. 

 

When this is complete, press Finish to update your encounter. 
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USING ENOUNTER DECKS 

You can use an encounter deck (see the section on Encounter Decks) to select creatures for 
an encounter. Open the encounter builder and choose the deck you want to use by selecting 
Use Encounter Deck from the Tools menu. Cards will be randomly drawn from the deck and 
added to the encounter; the encounter difficulty and XP value will be automatically updated. 

You can also draw an encounter from a deck by opening the list of encounter decks (select 
Encounter Decks from the Project menu) and pressing the Run Encounter button; you can 
optionally select a map to use for the encounter. 

AUTOBUILD 

If you don’t want to spend time building the encounter yourself, Masterplan provides an 
AutoBuild feature which will generate a level-appropriate encounter containing random 
creatures. 

You can exercise a degree of control over this process by selecting the Advanced option, 
which allows you to specify the encounter template, the difficulty of the encounter, the 
level of the party and the types of creatures that should be considered. 

 

ENCOUNTER NOTES 

You can add notes to your encounter to cover topics such as creature tactics, illumination 
and so forth – some blank notes are created to cover standard notes you may want to add. 
Any information you add here is displayed when you select the encounter in the workspace, 
and when the encounter is run. 
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TRAPS AND HAZARDS 

A plot point can contain a trap or hazard. To add a trap or hazard to a point, double-click on 
it; on the Game Elements page click the Trap or Hazard link. 
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This creates a blank trap. To set the trap information, press the Edit Trap / Hazard button 
on the toolbar. This allows you to change the trap’s statistics (such as level, role and attack 
data). 

Alternatively you can import a predefined trap / hazard from a library by pressing the Use 
Standard Trap / Hazard button; this clears the current trap and replaces it with the 
information from the selected trap. 

Note: You can add predefined traps and hazards to an encounter by opening the encounter 
builder and switching to Traps / Hazards on the toolbar above the right-hand list. 

SKILL CHALLENGES 

Like encounters, plot points can contain skill challenges. To add a skill challenge to a point, 
double-click on it; on the Game Elements page click the Skill Challenge link. 
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This creates a blank skill challenge. To set the skill challenge information, press the Skill 
Challenge Builder button on the toolbar. This allows you to change the level and complexity 
of the challenge (the challenge’s XP value will be updated automatically); the challenge level 
equals the party level by default. You can also enter the consequences of success and failure, 
and information about the skills which can be used in the challenge. 

Alternatively you can import a predefined challenge from a library by pressing the Use 
Standard Challenge button; this clears the current skill challenge and replaces it with the 
information from the selected challenge. 
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You can add skills to the skill challenge by moving to the Skills page and dragging them from 
the right-hand list into the left-hand list. You can then specify the skill’s DC level, and give 
details about how the skill should be used in the challenge. 



 

23 

 

 

You can track your party’s progress on a skill challenge from the Masterplan main screen. 

Note: You can add predefined skill challenges to an encounter by opening the encounter 
builder and switching to Skill Challenges on the toolbar above the right-hand list. 

QUESTS 

Like encounters and skill challenges, plot points can contain quests. To add a quest to a 
point, double-click on it; on the Game Elements page click the Quest button. 
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You can specify whether the quest is a major or minor quest, and specify the quest level 
(this defaults to the party level). The XP value of the quest will be automatically updated. 

MAPS 

You can also add maps to plot points. Once a map has been created (see the section on 
Tactical Maps) it can be added to a plot point by clicking the Map button on the Game 
Elements page. 
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You can now select the map to be associated with this plot point. 
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CAMPAIGN BACKGROUND 

You can set background information for your project using the Background tab. 

The default background items are Introduction, Adventure Background, Adventure Synopsis, 
DM Information, Player Introduction and Character Hooks; you can add and remove items 
as you see fit, and items can be re-ordered using the Move Up and Move Down buttons on 
the toolbar. 

 

When you create a new background item, or edit an existing one, you will see the following 
screen. You can use HTML tags in background item details. 
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THE ENCYCLOPEDIA 

When running a long-term campaign, you will often want to note down general information 
about NPCs encountered, towns and cities visited, etc. The Encyclopedia tab enables you to 
do this from within Masterplan. 

 

ADDING ENTRIES 

To create an encyclopedia entry, press Add on the toolbar. You can now enter information 
about the entry (including pictures, DM-specific information, and links between this and 
other existing entries). 
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There are two ways in which you can use more advanced formatting in encyclopedia entry 
details: 

 You can use HTML tags. 

 You can surround an entry name with double square brackets (using the syntax 
‘[[entry_name|display_text]]’) to create a link to that entry; links to missing entries 
will be displayed in red. 

Encyclopedia entries can also be created quickly in the following ways: 

 For a PC (from the list of PCs) or for an NPC or a custom creature; the encyclopedia 
entry will contain the stat block. 

 For a regional map location (from the regional map); the entry will contain a link to 
show the location on the map. 

 For a rules item on the Rules tab; the entry will contain the item’s write-up. 

DM INFORMATION 

Not all information in an encyclopedia entry will be information you want your players to 
have; Masterplan provides two ways to incorporate DM-only information: 

 An entry’s DM-only information can be added to the DM Information tab. 

 In the Public Information tab you can surround DM-only information with [[DM]] ... 
[[DM]] tags; anything within the tags is treated as DM information and will be 
displayed in bold. 

GROUPS 

In addition to entries you can also create groups by selecting Add Group underneath Add on 
the toolbar. Groups allow you to view collections of entries simultaneously. 
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ENCYCLOPEDIA ENTRY TEMPLATES 

You can define templates for your encyclopedia entries by saving them as HTML files and 
putting them in a folder named Encyclopedia in the main Masterplan folder. These 
templates are then available from the Add button on the Encyclopedia toolbar. 

USING THE ENCYCLOPEDIA 

You can link to encyclopedia entries from within plot points by opening the plot point 
window and selecting the Encyclopedia Entries page. 
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You can create a campaign bible by selecting Publish from the toolbar. This will bring up the 
Handout screen, and automatically add all encyclopedia entries to the handout. DM 
information is not included in the handout by default; you can change this by toggling the 
DM Info button on the toolbar. 

If you want to share your encyclopedia with other projects, select Export from the toolbar 
to save your encyclopedia entries. To import this encyclopedia file into another project, 
select Import from the toolbar. 
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CAMPAIGN RULES 

Masterplan allows you to define homebrew rules elements (such as races, classes, paragon 
paths, epic destinies etc) for use in your campaign. 

Each of these elements has its own designer and can be exported as a handout for your 
players. 

 

Rules items can be shared between projects by selecting Export or Import from the Share 
menu. 



 

33 

 

ATTACHMENTS 

If your Masterplan project depends on other files (for example, pictures you intend to use as 
player handouts) you can add these files into your project. 

 

You can import a file into your project either by pressing the Import button on the toolbar 
or by dragging and dropping a file onto the list. If you already have an attachment with this 
name in the project, you will be asked whether you want to replace the existing attachment 
or add the new one with a new name. 

You can open the file by selecting Extract to Desktop and Run from the Extract menu on the 
toolbar. This extracts the file to your desktop and opens it with the default application. If 
you do not want to open the file (or you want to open it with a different application) select 
Extract to Desktop instead. 
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THE JOTTER 

As you create your campaign you may need to write notes to yourself; this can be done 
using the Jotter tab. To create a new note, click Add Note on the toolbar and type your note 
directly into the application. 

This tab will also contain warnings about the project (for example, encounters and skill 
challenges which are too easy or too difficult; projects which do not include enough 
treasure parcels; skill challenges which have no skills defined). 
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IN-SESSION REFERENCE 

This page provides a quick reference which holds useful information for your gaming 
sessions. 

PARTY BREAKDOWN 

The party breakdown section shows you the essential statistics for your players’ characters, 
including the range of their defences, their passive perception and insight, and the 
languages they understand. 

Following this breakdown, information on each character in turn is shown. 

RANDOM GENERATORS 

This section provides a collection of random generators, such as names, potion descriptions, 
room descriptions, foreign text, etc. 
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INFORMATION 

The Information screen, available in the plot point screen, the encounter builder and when 
running encounters, shows a quick list of useful information. 

 

You can double-click the damage expressions to bring up a dice roller with those expressions 
pre-loaded. 
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PROJECT OVERVIEW 

The Project Overview option, available from the Project menu, allows you to quickly see all 
the encounters, skill challenges and treasure parcels which are contained in your project. 
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CAMPAIGN SETTINGS 

If you want to run a campaign or an adventure at a higher or lower difficulty than it was 
designed for, select Campaign Settings from the Project menu. 

 

This feature allows you to modify creature hit points, attack bonuses and defences, without 
changing the creatures directly. 
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TACTICAL MAPS 

Your project can contain a set of tactical maps, such as dungeons or castle keeps. Select 
Tactical Maps from the Project menu to see them. From here you can create new maps 
using the Add button, which brings up the Map Editor. You can also print your maps or save 
them as image files. 

 

MAP EDITOR 

The map editor allows you to build maps by dragging tiles from the right-hand list and 
dropping them onto the grid. 

You can press the Filter This List button to narrow down your list of tiles by library or 
keyword. 
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EDITING THE MAP 

You can reposition a selected tile by dragging it (or using the keyboard arrow keys) or 
change its orientation by selecting Rotate Left or Rotate Right from the toolbar (or by 
holding shift and using the keyboard arrow keys). You can remove a tile from the map by 
selecting it and pressing Remove on the toolbar or pressing the Delete key. 

You can select multiple tiles by holding the Control or Shift keys while selecting tiles, or by 
right-clicking and dragging to select a region and selecting Select Tiles from the menu that 
appears. You can then move, rotate or remove all the selected tiles as a group. 

You can also right-click on a tile and select Swap Tile; this will bring up a list of all the other 
tiles of that size; double-clicking on one of these tiles adds this tile in place of the original. 
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SCROLL AND ZOOM 

You can scroll around and zoom in and out of the map by selecting Scroll and Zoom from 
the Tools menu. When this is selected, click and drag with the mouse to scroll, and use the 
slider to zoom. In this mode you cannot edit the map; to stop scrolling and zooming, select 
Scroll and Zoom again. To return the map to its initial state, select Reset View from the 
Tools menu. 

MAP AREAS 

You can specify map areas (rooms etc) by right-clicking and dragging to select a region of the 
map. Select the Create Map Area option from the menu that appears. This allows you to 
name the area, and enter any additional details about it (such as illumination, room features, 
and so on). 
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You can change the map area by using the Move and Edit pages. 

 

The new area will appear in the Map Area list. When you select an area from the list, the 
view will zoom to that area. When no area is selected, the view will zoom out to show the 
entire map. 
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MAP AUTOBUILD 

As for encounters, Masterplan provides an AutoBuild feature for maps. This feature is 
available from the map editor’s Tools menu. 

When accessed, you are asked whether you want to create a dungeon map or a randomly 
filled rectangular area, and then specify which libraries to use when building the map. If you 
have a library which is not shown in the list, it may be because you have not specified the 
categories for its tiles. In the main screen select Libraries from the Tools menu and edit the 
tiles. 

For a dungeon map you can also specify the maximum and minimum number of areas you 
want your map to consist of, and the map will be built according to the categories of the 
tiles: 

 Plain: These tiles will be used to create rooms and corridors 

 Doorway: these tiles will be used to create doorways into rooms and in corridors 

 Stairway: these tiles will be used to end corridors 

 Feature: these tiles will be added to rooms after they are created 

 Special or Map: these tiles are not used 

For an area map you are asked to specify the dimensions of the area. 
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USING A BACKGROUND MAP 

If you want to extend an existing map, for example to add a new level to an existing 
dungeon, you can do this by selecting Select Background Map on the Tools menu. The map 
you select will be shown as a ghost behind the map being edited. 

 

If a background map is visible you can remove it by selecting Clear Background Map on the 
Tools menu. 

USING MAPS WITH ENCOUNTERS 

To associate an encounter with a map area, open the encounter builder and turn to the 
Encounter Map page. Press the Select Map button on the toolbar to choose the map which 
the encounter will use; the view will show the selected map area. 

A list will appear at the right showing the creatures in that encounter. Drag and drop each 
creature onto the map; when all the creatures have been added to the map, the creature 
list will disappear. 
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You can move creatures around the map by dragging them, but you cannot drag a creature 
off the map or onto another creature. If you move the mouse pointer over a creature, a 
tooltip will display its statistics. 

CUSTOM MAP TOKENS AND OVERLAYS 

You can add custom tokens to represent miscellaneous encounter features or mounts for 
other creatures, whereas custom overlays can be used to represent unusual terrain, area 
effects or map tiles. 

Select Add Custom Token or Add Custom Overlay from the Map Tokens menu. 
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Once placed on the map, the token or overlay can be moved around like other tokens, 
except that overlays can be moved off tiles and over other tokens. 

Overlays are always shown underneath other tokens, so they never get in the way when you 
are moving creatures or PCs around the map. Overlays have two display styles which you 
can select: Rounded, in which the overlay is translucent with rounded edges, and Block, in 
which it is rectangular and opaque. 

PRINTING 

You can print a map from the Tactical Maps screen by selecting Print Map from the Print 
menu. You are then presented with two options: 

 Print the entire map on one page; the map will be rotated and scaled to make the 
best use of the page area. 

 Print the map at a scale of 1” to a map square (to create poster-style maps). 

This screen also gives you the option to print sheets of blank 1” grid; to do this, select Print 
Blank Grid from the Print menu. 
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DELVE AUTOBUILD 

The Tactical Maps screen provides a Delve AutoBuild option for any maps which contain at 
least one area. This creates a randomly-generated encounter for each map area and placing 
creatures on the map. It also randomly assigns treasure parcels. With this option you can 
also use an encounter deck to build the encounters. 

TILE BREAKDOWN 

If you want to see how many tiles from each library make up a map, select it in the Tactical 
Maps screen and select Tile Breakdown from the Tools menu (this is particularly useful if 
you have sorted the map tiles into libraries based on which Dungeon Tiles set they come 
from). 
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REGIONAL MAPS 

Your project can contain regional maps (for example, maps of continents or cities). Select 
Regional Maps from the Project menu to see them. 

 

To create a new regional map, select Add. You can then name your map and select an image 
to be used for the map. 

You can also add locations to your map. Locations can be associated with a category (for 
example, a city map might have an Inn location, whereas a world map might have Mountain 
locations. 
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PLAYER CHARACTERS 

You can enter information about the PCs by selecting Player Characters from the Project 
menu. 

 

To add a new PC, click the Add button on the toolbar. You can now enter the character 
name, player name, and information on the character’s race and class. You can also add the 
character’s combat stats, passive insight and perception scores, languages, and select a 
portrait for the character. 

 

You can also import a character file from the Character Builder by selecting Import from 
Character Builder under the Add button (if a previous version of this PC has already been 
entered, its stats will be updated). 

You can also import a character (or all the characters in a campaign) from iPlay4e. Select 
Import iPlay4e Character or Import iPlay4e Campaign under the Add button and enter the 
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key (remember that for characters to be imported they must be marked as public on the 
iPlay4e website). If you have at least one iPlay4e character in your project, a button will 
appear to allow you to automatically refresh their statistics from the server. 

You can also use the Suggest a PC option, from the Add menu, to get Masterplan to suggest 
a class / race combination which might fill a role that the current party is lacking. 

PCs can be set as active or inactive by selecting the PC and pressing the Active button on the 
toolbar. This might be useful if, for example, a certain player will be unable to attend a 
session. 

Selecting the Overview tab shows the breakdown of role and power source of the party. 

 

PCS IN COMBAT 

To speed up combat, you can predefine effects (such as ongoing damage or status effects), 
map tokens and map overlay tiles for each PC. To do this, switch to the Combat page and 
press the Add button. 
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TREASURE PARCELS  

Plot points can contain treasure parcels. To add treasure parcels to a plot point, you first 
need to define the available parcels for your project. To do this, select Treasure Parcels 
from the Project menu. 

 

When you create your project, a random set of 10 level-appropriate treasure parcels are 
created for you automatically. 

You can add a set of parcels by selecting Add Standard Set from the Add menu on the 
toolbar – you can edit their details or remove them from the list with the Edit and Remove 
toolbar buttons. You can also add individual custom items by selecting Add Parcel from the 
Add menu. 
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It’s also possible to specify which PCs are given each parcel (for example, if you want to 
check that each character receives a comparable amount of treasure). You can do this from 
the plot point treasure parcel page, or from the treasure parcels screen. 

To add treasure parcels from this list to a plot point, double-click on the point and turn to 
the Treasure Parcels page. 

 

You add a treasure parcel by pressing the Add button on the toolbar (this button will be 
greyed out if there are no unassigned parcels in the project). You can then select the 
treasure parcel and it will be assigned to this plot point. 

If you want to remove a treasure parcel from a plot point, select the parcel and press the 
Remove button on the toolbar. This will move the parcel back into the list of unassigned 
parcels. 

CREATING MAGIC ITEM HANDOUTS 

You may find that you need to print out a reference sheet of magic items that you intend to 
give out to the PCs; to do this in Masterplan select Export Treasure List from the Tools 
menu to bring up the Treasure List screen – you can also access this screen by selecting 
Export Treasure List from the Advanced button on the Workspace page. 

On this screen you can select the magic items that you want to export; optionally, if you are 
using subplots to organise your campaign, you can select a subplot to show only the magic 
items that are available in this subplot. 
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When you press Export, an HTML file will be created which contains the magic items in a 
3x3 grid, which you can then print out and give to your players as they obtain them. 
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ENCOUNTER DECKS 

You can create encounter decks with which to build encounters. Select the Encounter Decks 
option from the Project menu. 

 

This shows the encounter decks in your project. To create a new deck, select Add from the 
toolbar; this will bring up the encounter deck builder. 
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To build an encounter deck, select a cell in the grid. The right-hand list will then be filled 
with all the creatures that can be added to that cell. Dragging creatures from the list onto 
the grid will add them into the deck. The grid shows the current number of creatures in each 
row, and (in parentheses) the recommended number of creatures. 

You can double-click on any cell in the table to see the creatures contained within it. 

 

If you don’t want to specify every creature in the deck, you can ask Masterplan to create a 
deck for you. Press the AutoBuild button at the bottom left of the encounter deck builder; 
you can now specify the level the deck should be built for (this defaults to the party level) 
and the types of creatures that the deck can contain. 

 

When you press OK the deck will be generated randomly, and the number of cards for each 
type of creature will be shown. 

Once a card is drawn from a deck it won’t be used again until they are added back into the 
deck; you can do this by opening the deck builder and pressing the Refill Deck button. 
Drawn cards are shown in the deck builder in grey. 
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CUSTOM CREATURES AND NPCS 

To create custom creatures or NPCs for your campaign, select Custom Creatures and NPCs 
from the Project menu. 
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CALENDARS 

You can create custom calendars for use in your campaign by selecting the Calendars option 
from the Project menu. 

 

To create a new calendar, press the Add button on the toolbar. You can then enter the days 
and months of your new calendar, as well as giving it a name. You can specify that months 
have a different number of days during leap years, and how often leap years occur. 
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You can enter the dates when seasons begin, and other important dates for your calendar 
(such as anniversaries, holidays and the like). 
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Masterplan will also keep track of the phases of any moons you enter. 
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If you have at least one calendar in your project you can set the dates on which plot points 
occur. A toolbar will be visible on the plot point Details tab which allows you to set the date. 
When a date is set, an additional button will be visible which allows you to clear this date. 
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CREATURE BUILDER 

The creature builder is used any time you want to create a creature (a standard creature in a 
library or a custom creature in an encounter), or an NPC. 

If you want to quickly adjust a creature’s difficulty, you can use the Level + / - buttons at the 
top right of the screen. 
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Clicking on the link in the top shaded section brings up the following screen: 

 

Clicking on any of the combat statistics will bring up the following screen: 

 

You can give your new creature resistances or vulnerabilities to certain damage types by 
clicking on the Resistances / Vulnerabilities / Immunities link. 
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Here you can specify your creature’s damage modifiers (a damage modifier is a resistance, 
vulnerability or immunity). 

 

To enter a power or trait, click the Add a Trait or Add a Power link. This allows you to enter 
the new power’s details. 
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Alternatively, you can quickly import a power from another creature by pressing the Browse 
for an Existing Power or Trait link. This brings up a screen from which you can browse 
creature powers and import them into your creature by pressing the Copy this Power Into… 
link. 

As in the encounter builder, you can press the Expand link to filter the list of creatures in 
various ways. 

 

You can also set your creature’s regeneration details; press the Add Regeneration link. 
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CREATING A VARIANT CREATURE 

In addition to creating new creatures, you can modify existing creatures. To do this, select 
the New Variant Creature option. You will first be asked to pick the creature to modify. 

 

If the creature is not a minion, you then have the option of applying templates to it. 
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If the template(s) you have selected do not match the role of the creature you have selected, 
you will be asked to pick which role the modified creature will fill. Pressing Finish on the 
final screen will open the creature for editing. 

CREATING AN NPC 

Creating NPCs follows a very similar process to that of creating custom creatures. To create 
a new NPC, select New NPC from the toolbar to bring up the NPC Designer. Note that you 
must have at least one class template in your libraries to create an NPC; to add a class 
template select Libraries from the Tools menu, choose a library to add your class template 
to, switch to the Templates tab, and add a template (making sure to change the template 
type to Class Template). 
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IMPORT / EXPORT 

EXPORT HANDOUT 

You can create player handouts by selecting the Export Handout option on the Tools menu. 

Player handouts can contain: 

 Background information items 

 Encyclopedia entries 

 Player options 

The Background, Encyclopedia and Rules pages all have a Share menu with a Publish option; 
select this to quickly add all the information from this page into a handout. 

 

In this screen the available handout items are shown in the list on the left. Drag items from 
the left-hand list into the centre list to add them to the handout; they can be reordered 
using the Move Up and Move Down buttons. The resulting handout is shown at the far 
right; press Export to save it as an HTML file. 
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IMPORTING A PROJECT 

You can use the Import Project command on the Tools menu to select a project and add 
information from it (plot structure, maps, etc) into the current project. 

EXPORT TO HTML 

You may prefer not to have your computer at the gaming table; for this reason, Masterplan 
provides the option to save your project as an HTML file. To do this, select Export Project 
from the Tools menu. 

EXPORTING A PLOT POINT 

You can save a plot point as an HTML file by selecting Export to HTML from the Share menu 
at the right-hand-side of the workspace page. 

You can also export a plot point as its own Masterplan project file, by selecting Export to 
File from the Share menu. The resulting file will contain all the information needed for that 
plot point. 

EXPORTING AN ENCOUNTER 

Some third-party tools, such as inCombat, can import and use encounter files from 
Masterplan. To create an encounter file, open the encounter builder and select Export 
Encounter File from the Tools menu. 
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RUNNING COMBAT ENCOUNTERS 

 

To run the combat encounter associated with a plot point, open the plot point and press the 
Run button on the Game Elements tab. Alternatively, if the encounter has a map, it will be 
shown in the preview pane when the plot point is selected in the workspace; double-click on 
it to run the encounter. 

The combat view shows a list of combatants on the left. If the encounter has a map 
associated with it, it will be shown with the opponents displayed as black tokens, whereas 
PCs are shown in green. PCs (and any creatures which are not on the map at the beginning 
of the combat) can be dragged from the list onto the map. This list is initially shown in one 
column; you can switch to a two-column view by selecting the option from the Combatants 
menu. 

The initiative scores for creatures are rolled automatically in groups (you can change this 
default behaviour by selecting Initiative Mode from the Combatants menu). You can edit a 
creature’s initiative score by double-clicking on it in the list. Double-clicking on a PC in the 
list (or dragging a PC onto the map) will prompt you to enter the PC’s initiative score. As PCs 
join the combat the encounter’s level and the amount of XP gained from it are updated. 

The slider at the right allows you to change the current initiative score. When it is a 
combatant’s turn they will be shown in bold in the list; on the map they are highlighted with 
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a blue outline. You can click the Next Turn button on the toolbar to automatically advance 
the current initiative score to that of the next creature or PC. 

To quickly determine which map token represents which creature in the list, select the 
creature in the list; the appropriate map token will be temporarily highlighted with a red 
outline. 

You can display line of sight information by selecting Show Line of Sight from the Map 
menu. When this is turned on, squares that no PC can see are automatically dimmed, and 
hovering over any token on the map or selecting any combatant from the list will highlight 
all squares that it has line of sight to. 

CREATURES IN COMBAT 

You can use a creature’s powers by selecting the creature (either in the list or on the map) 
and clicking on the name of the power. 

 If the power has been defined with an attack roll, this will be rolled for you 
automatically. 

 If the power is a limited use power (i.e. a per-encounter power, or a rechargeable 
power), Masterplan will offer to mark it as expended. 

Right-clicking on a creature (in the list or on the map) and selecting Details, double-clicking 
on a creature in the list, or clicking the Details button on the toolbar when a creature is 
selected, allows you to edit its hit points and initiative score. You can also set the creature’s 
altitude (in squares). 
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On the right hand side of this dialog there is a gauge showing the combatant’s current hit 
points (including temporary hit points, if any, in blue). This gauge will turn red when the 
combatant is bloodied. 

You can also use this screen to add ongoing conditions or damage by pressing the Add 
button. 

DAMAGE AND HEALING 

You can mark damage on a creature in any of the following ways: 

 Right-clicking on a creature (in the list or on the map) and selecting Damage 

 Double-clicking on a creature on the map 

 Clicking the Damage button on the toolbar when a creature is selected 

 Clicking on a creature’s HP in its stat block 

This will bring up the damage screen, which allows you to quickly deal damage to the 
selected creature. You can specify the type of damage that is being dealt; if the creature has 
resistance, vulnerability or immunity to that damage type, this will be taken into account. 
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When you press OK the damage will be applied to the creature; the damage will be taken 
from the creature’s temporary hit points first, if it has any. 

 

Similarly, you can heal creatures by selecting Heal from the toolbar, or from the right-click 
menu. 

 

When opponents are bloodied, they are displayed (in the list and on the map) in a dark red 
colour. When they are killed, they are automatically removed from the combat; you can 
disable this feature by deselecting Remove Defeated Opponents on the Options menu, in 
which case dead creatures will be displayed in light gray. 

ONGOING EFFECTS 

You can apply ongoing effects to a creature in any of the following ways: 

 Right-clicking on the creature in the list or on the map 

 Selecting Add Effect from the toolbar when a creature is selected 

You will be given the option to apply a predefined effect, or to create a new effect. 
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When you add a new effect, Masterplan will ask whether this has been applied by a PC; if it 
has, the effect will be added to that PC’s repertoire and you will not have to define it again – 
it will be available from the list automatically for all future encounters. Otherwise the effect 
will be added to the list for this encounter only. 

If a creature is subject to ongoing conditions or ongoing damage, this will be shown as a red 
badge on its map token. 

TRAPS, HAZARDS AND SKILL CHALLENGES IN COMBAT 

If the encounter includes traps or skill challenges these are included in the combat list. Traps 
which have an Initiative bonus have their Initiative score rolled automatically. 

MOVING DOWN THE INITIATIVE ORDER 

When you use the Next Initiative toolbar button or the Current Initiative link to advance 
the initiative count, Masterplan may prompt you about some combat-related housekeeping 
tasks before you regain control of the combat. 

If any of the creatures or PCs whose turn is now over are subject to ongoing conditions or 
damage, you will be prompted to roll saving throws for them. Masterplan will automatically 
remove the conditions which the creature saves against. 
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Some ongoing effects may last until the start or the end of a creature’s turn. You will be 
informed if any such effects have ended; you will have the option to extend them for 
another round. 

 

If any of the creatures whose turn is beginning are wounded and have regeneration, you will 
be informed about this. 

If any of the creatures or PCs whose turn is beginning are subject to ongoing damage, you 
will be prompted to apply that damage. Masterplan will take into account any damage 
resistances, vulnerabilities and immunities the creature may have. 
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If any of the creatures whose turn has now begun can recharge their encounter powers, you 
will be prompted to do this. If the power recharges on a D6, this will be rolled for you 
automatically. 

 

DRAWING ON THE MAP 

You may find yourself wanting to point out a particular dungeon feature, or indicate a plan 
of attack; Masterplan allows you to do this by drawing directly onto the combat map. To 
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activate this feature, select Allow Drawing from the Map menu (selecting it again turns the 
feature off again). Anything you draw on the DM map will be replicated on the player view 
map and vice-versa). 

You can clear the map’s current drawings by selecting Clear Drawings on the Map menu. 

 

LINKS BETWEEN MAP TOKENS 

If you drag one map token onto another, you can create a visible link between the tokens. 
This can be useful for noting marks and curses, for example. 

Dragging the tokens together a second time will clear the link. 
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ADDING CREATURES DURING COMBAT 

You can add new creatures / NPCs / traps / skill challenges to an encounter on-the-fly by 
selecting Add from the Combatants menu. The standard screen for creating encounters will 
appear; when you close it your encounter will be updated automatically. 

ADDING CUSTOM TOKENS AND OVERLAYS 

You can quickly add a custom token or an overlay to your encounter by dragging it from the 
Templates tab onto your map. 

LAYOUT 

If you are running Masterplan on a typical computer, the combat screen will be displayed in 
landscape mode – that is, with the list of combatants on the left, and the encounter map on 
the right. If instead you have a tablet or a slate, the combat screen will be shown in portrait 
mode – that is, with the encounter map below the combatant information. This default 
state can be overridden by selecting Landscape or Portrait from the Options menu. 

You can change the layout of the combat window to suit your preferences by using items on 
the Options menu: 

 One Column or Two Columns: specifies whether the combatant information is 
displayed in a single column or in two columns. 
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 Map at Right or Map Below: specifies whether the combat map, if one exists, is 
displayed on the right-hand-side or at the bottom of the window. 

In addition, you can change the columns which are visible in the list by selecting Columns 
from the Options menu. The available columns are: 

 Initiative, which shows the combatant’s initiative score 

 Hit Points, which shows the combatants current and total hit points, and any 
temporary hit points 

 Defences, which shows a creature’s defence scores 

 Effects, which lists any ongoing effects the creature or PC is affected by 

ENDING AN ENCOUNTER 

To end the encounter, press the End Encounter button. 

If you would like to pause the encounter and resume it at a later data, press the Pause 
Encounter button. You can resume the encounter by selecting Paused Encounters from the 
Project menu. 
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USING THE PLAYER VIEW 

If you are using Masterplan to run a game, you will often want to show certain information 
to your players. You can use the Player View feature to show various items to your players 
without showing them any other information. 

Use the Show command on the Player View menu to display or hide the player view. You 
can clear the current contents of the player view at any time by selecting Clear from the 
Player View menu. 

By default the player view will be displayed on a secondary display (such as a second 
monitor, a television or a projector), if one is available and connected. You can override this 
by deselecting Show on Other Display from the Player View menu. 

Plot points: When you have a plot point selected, you can use the Send to Player View 
option from the Share menu on the right-hand-side to show the point’s read-aloud text on 
the player view screen. 

Background items: When you have a background item selected, you can use the Send to 
Player View button on the toolbar to show the item on the player view screen. 

Encyclopedia: When you have an encyclopedia entry selected, you can use the Send to 
Player View button on the toolbar to show the text of the entry on the player view screen. 
The links to other encyclopedia entries are not shown. 

Attachments: When you have an attachment selected, you can use the Send to Player View 
button on the toolbar to show the attachment contents on the player view screen. This 
feature is only available for certain file types (plain text files, rich text files, image files, URL 
links, and HTML web pages). 

The party: In the player characters screen, press the Send to Player View toolbar button to 
send the list of PCs to the player view screen. 

Handouts: In the Export Handout screen, when your handout contains at least one item, 
you can use the Send to Player View button on the toolbar to show the handout on the 
player view screen. 

Player options: In the Player Options screen you can use the Send to Player View button on 
the toolbar to show the selected item on the player view screen. 

Calendars: When a calendar is selected in the calendar list screen, you can select Send to 
Player View from the toolbar to show the selected calendar on the player view screen. 

Combat: In the combat screen, select Show Map from the Player View menu (or Show 
Initiative List if there is no encounter map). This will bring up a copy of the current map on 
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the player view screen. The map on the player view will be identical to the main combat 
map, except for the following differences: 

 The initiative order is shown to the right of the map (this can be toggled on or off by 
selecting Show Initiative List on the Player View menu. Creatures which are invisible 
are not displayed on this list. 

 The creature initials (as shown on the main combat map) are replaced with the 
initials of the creature’s category. This can be changed with the Show Creature 
Labels option on the Player View menu. 

 Only visible creatures will be shown to the players; when a hidden creature is made 
visible it will automatically appear on the player view map. You can change this with 
the Fog of War option on the Player View menu. 

 Tooltips for creatures will indicate their general health status (not wounded / 
wounded / bloodied / dead) rather than their stats. 
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LIBRARIES 

Libraries contain sourcebook information – creatures, creature templates, traps, skill 
challenges and map tiles. You can browse your libraries by selecting Libraries from the Tools 
menu. 

Items can be moved between libraries using drag and drop; if you have a project open, the 
project will also appear so that items created in the project can be copied into external 
libraries for use in other projects. 

 

CREATURES 

To add a new creature, select a library. Turn to the Creatures tab and select Add from the 
toolbar. You can now enter the creature’s name, level, role, and so on. When you press OK 
the creature will be added to the library and can then be used in encounters. 

IMPORTING FROM ADVENTURE TOOLS 

If you have created creatures using the WOTC Adventure Tools suite you can import them 
into Masterplan by following these steps: 

 From within Adventure Tools, export the creature(s) to XML. 
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 In Masterplan, select Libraries from the Tools menu. 

 Select the library you want to add your creature to, and select the Creatures tab. 

 Press the Add button, select Add a Creature to bring up the creature builder, and 
then select Import from Adventure Tools from the Creature Options menu. 

 Choose the file to import. The creature will be imported and added to the selected 
library. 

If you have a number of creatures to import, you can follow this sequence instead: 

 In Masterplan, select Libraries from the Tools menu. 

 Select the library you want to add your creature to, and select the Creatures tab. 

 Press the Add button, and select Import Creatures. 

 Choose the file(s) to import. The creatures will be imported and added to the 
selected library. 

CREATURE DEMOGRAPHICS 

You can get a quick overview of the creatures contained in a library by selecting 
Demographics from the toolbar. 

 

CREATURE TEMPLATES 

To add a new creature template, select a library. Turn to the Templates tab and select Add 
from the toolbar. You can now enter the template’s name, role, statistic modifiers and 
powers. When you press OK the creature template will be added to the library and can then 
be used in encounters. 
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MONSTER THEMES 

You can also create monster themes to apply to all the creatures in an encounter. To add a 
new theme, select a library. Turn to the Templates tab and select Add Theme from the Add 
button on the toolbar. 
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TRAPS / HAZARDS 

Libraries can hold predefined traps and hazards. To add a trap or hazard, select a library. 
Turn to the Traps / Hazards page and select Add from the toolbar. You can now enter the 
information for the trap. 
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If you want to quickly adjust a trap’s difficulty, you can use the Level + / - buttons at the top 
right of the screen. 

SKILL CHALLENGES 

Libraries can hold predefined skill challenges. To add a skill challenge, select a library. Turn 
to the Skill Challenges page and select Add from the toolbar. You can now enter the 
information for the skill challenge. 
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The level and experience sections on the first page will be greyed out; when the challenge is 
added to a plot point or encounter the challenge’s level will be set and this information will 
be visible. 

MAGIC ITEMS 

Libraries can contain magic items, which are used in treasure parcels. To add a new item, 
select a library. Turn to the Magic Items tab and select Add from the toolbar. 
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MAP TILES 

To add a new map tile, select a library. Turn to the Map Tiles tab and select Add from the 
toolbar. 

You can now enter the tile’s dimensions, set the tile category (plain, doorway, stairway, 
feature or special – see the section on autobuilding maps for details) and, if appropriate, any 
keywords that you might use to describe the tile’s contents. 

You can press Browse to select an image file to be used for the tile, or set the colour to be 
used for blank tiles. 

When you press OK the tile will be added to the library and can then be used to build maps. 
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ADDING MULTIPLE TILES 

If you have a folder containing a number of image files to be used as tiles, you can add them 
all in one go by selecting the Add Folder option. Select the folder containing your tile images, 
and a tile will be added to the library for every image file in that folder (supported formats 
are BMP, JPEG, GIF, PNG and TGA). The system will attempt to determine the tile 
dimensions automatically, but it’s a good idea to go through the list of tiles to check this and 
make corrections as needed. 

When you load a folder in this way, all the tiles will be labelled with the ‘Special’ category by 
default. The map autobuilder does not use tiles which are in this category, so if you want 
these tiles to show up in the autobuilder you will need to go through and change the 
category of your new tiles. 
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PASSWORD PROTECTION 

If you are concerned about other people viewing your plot, you can give your project a 
password. To do this, select Password Protection from the Project menu. 

 

When a password is set, it must be entered whenever the project is opened. 
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CUSTOMISING MASTERPLAN 

STYLE SHEETS 

You can create custom style sheets for Masterplan to customize the look of the application. 

 Export any element to HTML and copy the contents of the <STYLE> section. 

 Create three files containing this copied text in the Masterplan folder: 

o Style.Small.css 

o Style.Medium.css 

o Style.Large.css. 

Masterplan will now use these style sheets for text in the application and on the Player View. 

ADD-INS 

You can extend Masterplan by writing add-ins for it using any supported .NET language. 

 In Visual Studio, create a new class library project. 

 Add a reference to the Masterplan application. 

 Create a new class which implements the Masterplan.Extensibility.IAddIn interface. 

Full API documentation is provided in the Masterplan.chm file. 

When your DLL is added to the Masterplan\AddIns folder (which you may need to create), 
the add-in will be loaded into the program the next time it runs. 
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PORTABILITY 

Masterplan is fully portable; if you move your Masterplan folder onto a USB stick you can 
run the application from any device that has .NET 3.5 installed. 

In addition, each Masterplan project file contains all the necessary library items it requires 
(creatures, map tiles, etc) so you can even open your project with a copy of Masterplan that 
has no libraries installed. 

However, library files themselves cannot be moved to a different machine; this is to prevent 
copyright infringement issues. 
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